[Open-scap] getting started with source (autoconf on OSX)

Jan Ruzicka jan.ruzicka at comtechmobile.com
Thu Oct 20 00:37:48 UTC 2011


Inspired by attempts of others I tried to compile openscap on OS X 10.6.8
(with Xcode and MacPorts)
My attempt ended even before make.

I got the oscap source using
$git clone git://git.fedorahosted.org/git/openscap.git

Then, I tried ...

that gave me:
lib/Makefile.am:47: GL_GENERATE_ALLOCA_H does not appear in AM_CONDITIONAL
lib/Makefile.am:118: GL_GENERATE_ERRNO_H does not appear in AM_CONDITIONAL
lib/Makefile.am:151: GL_GENERATE_FLOAT_H does not appear in AM_CONDITIONAL
lib/Makefile.am:220: GL_GENERATE_STDDEF_H does not appear in AM_CONDITIONAL
lib/Makefile.am:249: GL_GENERATE_STDINT_H does not appear in AM_CONDITIONAL
autoreconf: automake failed with exit status: 1

It seems like issue, but I don't know how to get around it.

The ./configure runs, but fails with:
checking for gcry_check_version in -lgcrypt... no
configure: error: library 'gcrypt' is required for GCrypt.

Is the gcrypt referring to the libgcrypt library from gnupg?

It got a bit further by pointing to macports lib directory.
          (LDFLAGS=-L/opt/local/lib ./configure  --includedir=/opt/local/include)

           it couldn't find libapt-pkg  (macport for apt doesn't compile for me now)
           Other missing are:   blkid, libnl-1, libselinux, rpm (even with macport installed)

Did anybody else try to compile on OS X? any tips how to proceed?


checking for perl... /opt/local/bin//perl
checking for atomic builtins... no
configure: !!! Compiler does not support atomic builtins. Atomic operation will be emulated using mutex-based locking. !!!
./configure: line 21255: syntax error near unexpected token `probe_dir,"${libexecdir}/openscap"'
./configure: line 21255: ` EXPAND_DIR(probe_dir,"${libexecdir}/openscap")'

configure:21041: gcc -o conftest -g -O2 -pipe -std=c99 -W -Wall -Wnonnull -Wshadow -Wformat -Wundef -Wno-unused-parameter -Wmissing-prototypes -Wno-unknown-pragmas -D_GNU_SOURCE -DOSCAP_THREAD_SAFE -D_POSIX
_C_SOURCE=200112L  -march=i686  -L/opt/local/lib conftest.c  >&5
conftest.c:1: error: CPU you selected does not support x86-64 instruction set

aclocal (GNU automake) 1.11.1

Jan Ruzicka
Senior Software Engineer
Comtech Mobile Datacom Corporation
20430 Century Blvd, Germantown, MD 20874
Office: 240-686-3300
Fax: 240-686-3301

The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please so notify the sender immediately, and delete it and all attachments from your computer and network.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/open-scap-list/attachments/20111019/175f242f/attachment.htm>

More information about the Open-scap-list mailing list