[Ovirt-devel] [PATCH]: Tested, working implementation of migration

Ian Main imain at redhat.com
Fri Aug 15 05:06:16 UTC 2008

On Tue, 12 Aug 2008 10:41:42 +0200
Chris Lalancette <clalance at redhat.com> wrote:

>     An actually working, tested cut of the migration code for taskomatic.  It
>     supports 3 modes:

I tried to get this to work but I'm having a number of issues.  I fixed
one bug with migrating to an unselected host, but the migrate itself is
still failing.  It's getting late so I'm going to bed :)

Here's the main error I was getting:

libvir: QEMU error : operation failed: migrate failed: migrate
"tcp://node13 Task action processing failed: Libvirt::Error: Call to
function virDomainMigrate failed ./task_vm.rb:487:in `migrate'

I tried to get libvirt debug output but never saw anything interesting.
I probably just needed to redo it and look harder.

There are numerous other bugs around migration mostly in the UI from
what I can see. Selecting hosts to migrate to doesn't work sometimes,
sometimes I got errors that migrage_vm wasn't a valid action etc.

I updated the patch to fix one buglet with migration and errors and got
rid of whitespace. I'll post it shortly.

I'll keep poking at it in the morning.  Next step I think is to try a
straight migration just using libvirt and make sure that works before
testing the taskomatic changes.


More information about the ovirt-devel mailing list