[Ovirt-devel] root access required?

Ben Guthro bguthro at virtualiron.com
Mon Sep 8 15:58:42 UTC 2008


In my endeavor to set up a build environment for our developers experimenting with oVirt / libvirt, I have come across a general dislike that the build of the ovirt managed node requires the user to be root.

In looking into this we have found 2 areas that I am unable to work out a solution for:

1. livecd-tools must mount a filesystem image, requiring:
    (a) losetup /dev/loopX fs-image
        Where the user must have write access to /dev/loopX (which by
        default is writable only by root, readable by group 'disk'). Could be
        worked around by changing /dev/loopX permissions (once, as root).
    (b) mount /dev/loopX /mnt/point
        Also requires root. Can be worked around with /etc/fstab entry
        allowing user mount.

2. 'rpm --root ...' is used to build the image.
    --root must chroot to the specified directory to run the various RPM scripts.
    chroot can't run under 'fakeroot' (AFAIK).
    I don't know how to avoid or workaround this.

So -
Does anyone here have any suggestions/recommended practices on how to go about working around these so that root access is not required?

Or - are we stuck with "that's just the way it is" for building the managed node image?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/ovirt-devel/attachments/20080908/615052a7/attachment.htm>

More information about the ovirt-devel mailing list