[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem w/passwd since installing shadow-utils / pam



> > I've recently installed the Pam and shadow-utils (plus the
> > libpwdb) rpms.  I ran the pwconv5 utility to convert to shadow
> > passwords.  The conversion ran smooth on the third attempt.  Now,
> > however, when I attempt to change a users password, it doesn't
> > work.  The passwd utility comes back and says that is succeeded in
> > updating all the tokens, but the password hasn't changed.  Do I
> > need an updated passwd program?  If so, where can I find it?

I solved the problem just earlier today... I'm using a modified 
version of the /usr/sbin/adduser v1.2 script to add users.  I'm quite
new to the whole PAM thing (I've been reading up on it furiously for
the past few days).  It seems that the format of the /etc/shadow file
is a little different from the one that adduser was creating.  I
modified adduser to create the password field in the right position,
and Voila!

So it's not a PAM or passwd problem, it's an adduser problem.

---
Steve Clarke
System Administrator,
Avalon InterConnect
http://www.avalon.nf.ca
Tel. (709) 739-6153



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []