[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Behavior of module that support /etc/nologin



On Mon, 31 Mar 1997, Andrew G. Morgan wrote:
[...]
>This is not the behavior I see.  I guess you are sticking with older
>utilities..
>
>I am using SimplePAMApps-0.54-1, pam-0.57-5 and pwdb-0.54-7.

I've got pam-0.57-5 and pwdb-0.54-7, but no SimplePAMApps, as Christian
doesn't include it in his Red Hat Linux packages.  What I'm seeing
is what RHL41 users will see with Chris' packages installed with no
special tweaking.

My /etc/pam.d/login is attached.  To correct the /etc/nologin problem,
is it enough to simply swap the following two lines:

auth       required   pam_pwdb.so shadow md5 nullok
auth       requisite  pam_nologin.so

so that they are instead ordered:

auth       requisite  pam_nologin.so
auth       required   pam_pwdb.so shadow md5 nullok

--
    Steve Coile           P a t r i o t  N e t      Systems Engineering
 scoile@patriot.net      Patriot Computer Group        (703) 277-7737



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []