[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: su fails




On Mon, 22 Sep 1997, Dave Wreski wrote:
> > >> Your problem was using pam_unix_auth.so instead of pam_pwdb.so.
> > >> pam_unix_auth.so does not read md5-crypted passwords.
> > >
> > >This is /etc/pam.d/su that your talking about?  I'm not using
> > >pam_unix_auth.so anywhere in that file:
> > 
> > You said that you wer using pam_unix_auth.so in your samba configuration
> > file.
> > 
> > Since you have md5 passwords, don't use pam_unix_auth in ANY file in
> > /etc/pam.d/ at all.  They all need to be pam_pwdb.so.

Umm.. I thought it worked.  I now have no occurences of pam_unix_auth in
any file in /etc/pam.d, as all of them have been replaced with pam_pwdb.

It still doesn't work.  Can you check my /etc/pam.d/su file again:

auth       required   pam_wheel.so use_uid
auth       sufficient pam_rootok.so
auth       required   pam_pwdb.so shadow md5
account    required   pam_pwdb.so shadow md5
password   required   pam_pwdb.so shadow md5
session    required   pam_pwdb.so
session    required   pam_limits.so shadow md5

Thanks,
Dave




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []