[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

dlerror: /lib/security/pam_pwdb.so: undefined symbol: pam_fail_delay]



Ok,  here's   my  problem:  if   I  install  any  version   of  glibc-2.0.7,
libdl-2.0.7.so causes pam to break.

I was able to upgrade to glibc-2.0.7-7, except for the following 3
libraries:
/lib/ld-2.0.7.so
/lib/libc-2.0.7.so
/lib/libdl-2.0.7.so

(I kept the versions I had with glibc-2.0.6)

I kept libc-2.0.6.so and ld-2.0.6.so because they seem to be tied to libdl
version and if I use the libdl from *any* glibc-2.0.7, I get:

mai 17 09:02:04 moremagic pam[1799]: unable to dlopen(/lib/security/pam_pwdb.so)
mai 17 09:02:04 moremagic pam[1799]: [dlerror: /lib/security/pam_pwdb.so: undefi
ned symbol: pam_fail_delay]                                                     
su: Unknown Linux-PAM error                                                     
mai 17 09:02:04 moremagic pam[1799]: adding faulty module: /lib/security/pam_pwdb.so

End result: I can't log in, I can't su, I can't do anything that uses pam.

moremagic:~# rpm -qf /lib/security/pam_pwdb.so
pam-0.59-5
moremagic:~# rpm -V pam-0.59-5
moremagic:~#

I really don't get it.

Does anyone have a clue what's going on?

Thanks,
Marc
-- 
Home page: http://magic.metawire.com/~merlin/ (browser friendly)
Finger merlin@magic.metawire.com for PGP key and other contact information
***** "God is real, unless declared integer." *****



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []