[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PAM + SSH + SOLARIS: It compiles but I get "Exit on signal 11" errors



Does anyone any suggestions as to what I should try next in diagnosing this
problem

Here is what I've tried:

I downloaded Matt Drown's patch and applied it.

I did a test compile of ssh-1.2.26 with Matt's patches on a RedHat 5.1 i386
machine and that copy of sshd worked like a charm.

I then compiled a clean distibution of ssh-1.2.26 on a solaris 2.6 machine.
That worked fine, that sshd used the system's passwords without a problem.

Lastly I applied Matt's patch and compiled ssh-1.2.26 on the solaris
machine. The configure/compile went without a complaint. So I added the
proper entries in the pam.conf and ran sshd in debug mode. I am using the
pam_smb_auth module to authenticate off of an NT primary domain controller.
I've tested the pam module with ftp and telnet and it works fine. So when I
connect to the pam patched sshd on the solaris machine and enter an
incorrect password, it correctly tells me my password is incorrect and
disconnects me. If I enter a correct password the sshd server promptly
exits with a Signal 11.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []