[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Unusual PAM logging



hi everyone,

this already happened to me thrice this month and i could not determine
the cause of this unusual dumping of pam to syslogd. i'm running Redhat
5.0 with all the patches applied (except for sysklogd).

Nov 24 14:22:53 atlas pam[16699]: _pam_init_handlers: no default config /etc/pam.d/other
Nov 24 14:22:53 atlas pam[16699]: error reading PAM configuration file
Nov 24 14:22:54 atlas pam[16699]: pam_start: failed to initialize handlers
Nov 24 14:22:54 atlas pam[16699]: pam_end: NULL pam handle passed

the four lines are repeated in /var/log/messages and syslog doesn't seem
to stop unless your reboot the server. at first, i suspected the kernel to
be the culprit and downgraded from 2.0.36 to 2.0.35. then, still
exhibiting the same behaviour, i downgraded the sysklogd package from the
fixed version to the stock package that came with Redhat 5.0. but this
afternoon, it still dumped more of the above messages and i had to reboot
the server again.

what could be the problem?? why is PAM complaining about no default config
`/etc/pam.d/other' when the file exists? is there a bug in PAM? btw, my
PAM package version is pam-0.64-2.

---
francis vidal   university of st. la salle, bacolod city, philippines
. . . . . . .   PGP key available via e-mail / subject: get PGP key
u s l s N E T   tel. nos. (6334).435.2324 / 433.3526



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []