[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PAM-Kerberos problems



: Either link the module with -lc or make gcc be involked with at least -O2
: optimization

When linked with -lc, I get this...

mkdir -p ./dynamic
gcc -g  -O2 -I/usr/local/krb5/include
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/builds/redhat-libc-5.4.x/krb5/include
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/builds/redhat-libc-5.4.x/krb5/include/krb5
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/builds/redhat-libc-5.4.x/krb5/include/kadm5
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/builds/redhat-libc-5.4.x/krb5/kadmin/passwd
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/src/krb5/include
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/src/krb5/include/krb5
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/src/krb5/include/kadm5
-I/afs/ncsa.uiuc.edu/src/kerberos/scratch/src/krb5/kadmin/passwd
-DUSE_KADM5_API_VERSION=1   -c pam_krb5.c -o dynamic/pam_krb5.o
ld -x --shared -o pam_krb5.so dynamic/pam_krb5.o  -L/usr/local/lib
-L/usr/local/krb5/lib -lc -lkadm5clnt -lgssrpc -lgssapi_krb5 -lkdb5
-lkrb5 -lcrypto  -ldyn
/afs/ncsa.uiuc.edu/src/kerberos/scratch/builds/redhat-libc-5.4.x/krb5/lib/libdb.a
-lcom_err
ld: pam_krb5.so: undefined versioned symbol name xdr_wrapstring@@GLIBC_2.0
ld: failed to set dynamic section sizes: Bad value
make: *** [pam_krb5.so] Error 1                         

Someone had mentioned the -lc trick before... and I tried that, but I got
those errors.  Any idea how to fix that problem?

Thanks...

/tmy

-- Diving into infinity my consciousness expands in inverse
   proportion to my distance from singularity




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []