[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dlerror: undefined symbol: yperr_string



On Mon, 20 Sep 1999, Thorsten Kukuk wrote:

> It really seems we have make a mistake and pam_unix_auth.so is not linked
> against libcrypt. But with the default SuSE Linux 6.2 configuration,
> we uses the SuSE special pam_unix.so Module, not the pam_unix_*.so
> Modules. Please change the configuration files back to the default.
> The SuSE pam_unix module can do all the things pam_unix_*.so can do, too.
> And contains a lot of more features.

Many thanks for the hint, it solved my problem!

In fact, I had a leftover /etc/pam.d/other which looked like:

auth    required  /lib/security/pam_unix_auth.so
account required  /lib/security/pam_unix_acct.so
password required /lib/security/pam_unix_passwd.so
session required  /lib/security/pam_unix_session.so

I've created the file following the instructions given in the PAM docs
("If something goes wrong") because after upgrading, I was completely
locked out. Only login in single user mode was possible. There I created
the 'others' file and obviously forgot about removing it again. <:) 

Anyway, everything works now. :-)
Thanks again,
Walter

-- 
Walter Haidinger <walter.haidinger@gmx.at>
For further information, such as address or PGP public key,
please refer to: http://members.kstp.at/wh/index.html





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []