[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Wohoo - 'passwd' update problems resolved at last



Lo all,

After approximately 1.5 weeks I have figured out why pam_ldap-66 would not
work when using the 'passwd' program on my RedHat6.2 box. I have read
countless FAQs/books/mailing lists, hounded people for answers, had many
sleepless nights and all over this word ->> use_authtok

This is the error you get without it:
##########
passwd: User not known to the underlying authentication module
##########


I am including my /etc/pam.d/passwd file for future newbies.

#%PAM-1.0
auth       sufficient	/lib/security/pam_ldap.so
auth       required     /lib/security/pam_unix_auth.so use_first_pass
account    sufficient	/lib/security/pam_ldap.so
account    required     /lib/security/pam_unix_acct.so
password   required	/lib/security/pam_cracklib.so retry=3
password   sufficient	/lib/security/pam_ldap.so use_authtok
password   required     /lib/security/pam_pwdb.so try_first_pass



Many thanks to all who sent me files/advice!
Ross





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []