[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

pam_{unix,pwdb}: crypt/md5 necessary?



Hello!

In the pam_{unix,pwdb} modules, there are an implementation of md5,
bigcrypt etc.  Just for curiocity: are them needed on linux (or, on
system with glibc) where "old good" crypt already handles md5 passwords
via "magic" salt?  If I remove (conditionally exclude) those routines
from that modules -- will it be ok?  And what condition should be
tested (i.e. what preprocessor define) for this?
(I think that implementing this routines on glibc-based system is just
a waste of resources, not big but anyway...).

Can someone comment on "legacity" of making such changes?

Regards,
 Michael.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []