[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Unable to login (No password prompt)



On Thu, 9 Nov 2000, Stephen L. McMahon wrote:

> For some reason, today I tried to login to my mail server (and secondary DNS
> server) and got immediately returned to the login prompt without being
> prompted for a password.  I have scoured the web for a good solution and
> found none.  The mail server works fine, I can check my mail using POP3 and
> I can ftp into the machine with no problem.  I tried rlogging into it from
> another machine and I get a password prompt, but it immediately rejects and
> disconnects.  I booted into single user mode and checked a few things out
> but I can't see a problem.  inetd.conf looks fine and the login executable
> exists.  I re-installed PAM but it had no effect.
>
> Can someone help me out here?  I really need to get into that machine!

1) Check the logs
2) Replace the login binary and PAM binary's with those from the distrib.
Returning to the prompt probably means that the PAM system encountered
something it couldn't handle, or it sigsegv's. Yes, I had that a lot when
debugging:-))
3) Try configuring the login service with the allow al thing. It's in the
PAM faq.


If you need additional help contact me in private.


> Thanks in advance to anyone who responds.
>
> Stephen L. McMahon
> smcmahon@datanetdg.com


	Igmar





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []