[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Solaris 8 / pam_krb5 / PROBLEMS... ;-(



Make sure you've compiled everything with -fpic or -Kpic or whatever
your compiler's flag is that turns on position independent code.

And make sure you link against shared Kerberos libraries. MIT krb5 can
only be configured to build static or dynamic libraries (see
--enabled-shared option to ./configure). So watch out.

As for my patches to Frank Cusack's module, expect them in sourceforge
sometime next week.

Nico


On Thu, Apr 05, 2001 at 05:29:07PM -0500, Steve Langasek wrote:
> Hi Michael,
> 
> On Fri, 6 Apr 2001, Michael Bischof wrote:
> 
> > I've some problems with Sun Solaris 8 and pam_krb5.
> > I'm using the MIT Kerberos 1.2.2 and pam_krb5 from
> > www.fcusack.com (Didn't work with the original pam_krb5
> > from Solaris). I removed also all original kerberos utilities
> > of Solaris 8 (klist, kinit, ... all libs, ...)
> 
> > My pam.conf: (just a part...)
> 
> > --- snip ---
> > dtlogin auth sufficient /usr/lib/security/$ISA/pam_krb5.so.1
> > dtlogin auth required   /usr/lib/security/$ISA/pam_unix.so.1
> 
> > other   auth sufficient /usr/lib/security/$ISA/pam_krb5.so.1
> > other   auth required   /usr/lib/security/$ISA/pam_unix.so.1
> > --- snip ---
> 
> > The dtlogin works fine, but I cant lock the screen ;-((
> > If I enable debug I can see the following error:
> 
> > ...load_modules: can not open module /usr/lib/security/pam_krb5.so.1
> 
> > But the file is there!?
> 
> This error message suggests to me one of two problems:  either PAM cannot load
> the module because it can't find some of the libraries it depends on, or it
> literally cannot open the module because of permissions problems.  Does
> 'ls -l /usr/lib/security/pam_krb5.so.1' show that the file is world-readable?
> 
> You (and others) may be interested to know that there is now also a CVS tree
> for pam_krb5 development at the Linux-PAM SourceForge site
> <http://sourceforge.net/projects/pam/>.  Development has only just begun, so
> the CVS version currently provides only minimal advantages over the 1.0
> tarball, but it will eventually include a number of Solaris fixes that Nicolas
> Williams has been hashing out over the past month or so.
> 
> Regards,
> Steve Langasek
> postmodern programmer
> 
> 
> 
> _______________________________________________
> Pam-list mailing list
> Pam-list@redhat.com
> https://listman.redhat.com/mailman/listinfo/pam-list
--





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []