[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Can't Login to Redhat7.2 using nis ???



Hello all ,
 
I am running a redhat 7.2 machine with the regular pam rpms that came with the distribution .
The rpms are :
----------------
1) pam_krb5-1.46-1
2) pam_smb-1.1.6-2
3) pam-0.75-14
4) pam-devel-0.75-14
 
I am having a problem using nis authentication with this pam rpms ,
every time i try to login i am getting a message in /var/log/messages :
sshd(pam_unix)[4575]: authentication failure; logname= uid=0 euid=0  tty=ssh  ruser=  rhost=kuku.domain.com user=kuku1
 
I have to say that it doesnt metter what authentication method i use , i can use telnet or ssh or any other application , i get the same response .
 
Both default authentication schems are enabled on my system from redhat installation setup :
shadow & md5 .
 
My nis server is running shadow password authentication , but in the system it self the md5 & shadow are both enabled .
The ypserv version is :
-----------------------
ypserv-1.3.9-3
 
 
My pam.d/system-auth :
-------------------------
auth        required    /lib/security/pam_env.so
auth        sufficient    /lib/security/pam_unix.so like_auth nullok
auth        required     /lib/security/pam_deny.so
 
account   required     /lib/security/pam_unix.so
 
password  required   /lib/security/pam_cracklib.so retry=3 type=
password  sufficient   /lib/security/pam_unix.so nullok use_authok md5 shadow nis
pasword    required   /lib/security/pam_deny.so
 
session       required   /lib/security/pam_limits.so
session       required   /lib/security/pam_unix.so
 
 
 
I must say that when i changed the pam_unix.so to pam_pwdb.so in each of the pam_unix.so
entries everything started to work . I guess it is because pam_pwdb use by default the shadow password authentication scheme .
 
So I don't understand why redhat6.2 for example use pam_unix.so module and everything works fine and under redhat7.2 it doesn't work ,,, when i actually installed the machine from scratch and using the regular pam module configured by the redhat installation setup to use both md5 & shadow & nis .
 
All my other machines are perffectly working  except the 7.2 distribution .
 
I would really like an answer to this problem because i did my best to solve the problem but
i still don't understand why it doesn't work .
 
Thanks .
 
Best Regards
Nissim Penias .


Get your FREE download of MSN Explorer at http://explorer.msn.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []