[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

PAM + SAMBA



Hi everyone,

I've been trying to get SAMBA 2.2.x up and running as a PDC and NT domain logon server 
for a few client machines running win98se/winme.  The unix machine is an intel x86 running 
RedHat Linux 7.0.  I tried the SAMBA 2.2.0 rpm first and was unable to get it working.  I kept 
getting log messages of the following sort for each attempted authentication from a client 
machine:

[2001/07/23 04:42:26, 0] passdb/pampass.c:smb_pam_passcheck(830)
  smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User mdt !

I thought maybe the problem was with the rpm, so I nuked it and installed SAMBA 2.2.1a 
**from the source code** using the --with-pam and --with-smb_pam options to the ./configure 
script.

No success:  same error messages when I try to authenticate.

I have a moderate level of experience with linux, but know **nothing** about PAM.  Can 
anybody tell me what I need to do to get this working?

By the way, I have plain-text passwords enabled for both the SAMBA server (as is the default) 
and for the windoze clients (edited registry).  I have done this to avoid dealing with the 
problem of keeping the unix and smb passwords in sync.  Could this be causing the problem 
with authentication?

Thanks in advance,

Mike Traynor, Vancouver, BC, Canada.






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []