[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

PAM + Apache



	I've been trying to put apache's authentication to work with pam,
but I'm getting several problems. As I see a recent non-ended discussion
about this in the list, i'd like any help.


	First, about my apache:
	I compiled mod_auth_pam staticly, and it seems to be ok.

	Server: Apache/1.3.19 (Unix) mod_auth_pam/1.0a PHP/4.0.4pl1

	Then, the error from the log:

	[Tue Apr  2 11:45:24 2002] [error] (2)No such file or directory: Tentando autenticar...
	[Tue Apr  2 11:45:24 2002] [error] (2)No such file or directory: access to / failed for 192.168.1.1, reason: Authentication failure

	This is what apeers in the log when I try to put my user and
password in apache's auth box. Note that "Tentando autenticar" is a
modification that a made in the module so that I could be sure apache was
calling it.

	From my /etc/pam.d/httpd

	#%PAM-1.0
	auth       required     /lib/security/pam_pwdb.so shadow nullok
	account    required     /lib/security/pam_pwdb.so

	This is how the file is now, but i tried several stuff here.


	I don't think it matters, but my .htaccess file is:

	AuthPAM_Enabled on
	AuthType Basic
	AuthName "secure area"
	require group rafael
	require user rafael

	User and group rafael exists. I think AuthPAM_Enabled, according
to documentation is not necessary, but it does not work with or without
:-(

	I compiled apache with the -ldl -l... as asked in pam.sf.net

	Well, that's it. Any help will be thankful.

[]s Rafael.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []