[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: SRP/EPS and RedHat 7.2



On Dec. 18, 2001, Tom Wu wrote:

> > Robin Redmile-Gordon wrote:                                             
> >                                                                         
> > If anyone can help on this subject I would greatly appreciate
> > a dialogue.  Recently installed new RedHat 7.2 server.
> > Downloaded the the eps_i386_linux6 and srp_i386_linux6 tars
> > from srp.stanford.edu.
> >
> > [...]
> >
> > I have kept several root sessions open whilst I'm doing that.
> > Just as well because I can't login from any other consol
> > terminal or from a telnet.
> >                                                                         
> > [...]
> 
> What exactly happens when you try to log in?  Are you getting a
> "password incorrect" or "login incorrect" when you enter the
> right password?  If the login succeeds with an empty password,
> then you've hit upon a VERY nasty bug in recent PAM
> implementations.
> 
> > Regards Robin
> 
> Tom                                                                       

Hi, I seem to be having exactly the same problem installing SRP 1.7.5
under RedHat 7.3 (same symptoms, anyway). Yes, it says the right
password is incorrect, and, yes, it allows me to login with an empty
password. (The old su and login work fine, by the way.)

This message is from a long time ago, but I don't see any
followups. Is there indeed such a bug in PAM, and if so is there some
way to fix or work around it, or is SRP not usable at the moment?

Thanks,
-- 
 Abe Stone
 abestone@uchicago.edu
 (or abe_stone@post.harvard.edu or abestone@ix.netcom.com)





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []