[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

mod_auth_pam trouble



Hello,
I'm trying to use the mod_auth_pam Apache module and having some trouble.
From what I can tell, the module never makes a call to PAM. Here are my
config details:

- RedHat 7.3 with Apache 1.3.23
- mod_auth_pam 1.1.1, compiled and installed according to the included instructions (make, make install, ...)
- In httpd.conf:


LoadModule pam_auth_module modules/mod_auth_pam.so
AddModule mod_auth_pam.c
...
<Directory "/var/www/html/test">
  DirectoryIndex index.html
  AuthType Basic
  AuthName "Test PAM"
  Require valid-user
  # also tried Require user username
  AllowOverride None
  Allow from all
</Directory>

- In /etc/pam.d/httpd:

auth        optional     /lib/security/pam_warn.so
auth        required     /lib/security/pam_permit.so
account     optional     /lib/security/pam_warn.so

I've also tried the stock config file included with mod_auth_pam:
auth    required /lib/security/pam_stack.so service=system-auth debug
account required /lib/security/pam_stack.so service=system-auth debug

In the syslog file, I see nothing (where I would expect PAM messages to show up). In the apache error log, I see:
[error] (13)Permission denied: access to /test/ failed for XX.XX.XX.XX, reason: Authentication failure


The user I'm trying to authenticate with *does* exist on the machine. There's no indication that the module isn't loading (Apache doesn't complain with httpd -t).

I'm stuck. Any ideas what's happening here?

Thanks,
-MW

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []