[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: problem for openssh and pam

Thanks for helping me to solve my problem about kerberos and openssh.
I have installed required rpms for Rh7.1 : openssh-2.9p2-1eds.i386.rpm
openssh-server-2.9p2-1eds.i386.rpm openssh-client-2.9p2-1eds.i386.rpm
from   Simon Wilkinsn Site.                               
I have configured sshd_config and ssh_config to enable kerberos Authentication
but I have got the same error  in running sshd: Bad configuration option :
 kerberos Authentication
I have installed openssh-3.0.2p1 and related patches for kerberos (openssh-3.0.2p1-krb5.patch and openssh-3.0.2p1-gssapi.patch )
In compiling I have enabled kerberos but it gives me an error for
"  not finding krb.h  " .So I couldn't install openssh3.0.2 from tar file.
If I am wrong in some phases please tell me , or any suggestions ?
I really appritiate any help.
----- Original Message -----
Sent: Wednesday, February 13, 2002 2:50 PM
Subject: problem for openssh and pam

I am using RH7.1 .I want to setup a Kerberos 5 client with Kerberos-enabled OPENSSH.
I have installed following rpms:
I have attached my /etc/pam.d/sshd and /etc/pam.d/system-auth .
I run kinit and then  want to ssh to another kerberized machine
without a password , but it promts to me for password.
I must emphasize that I have a Kerberos server and
it is acting correctly , and  on KDC i have add principal for that kerberized machine which I want to login
and made a keytab for that machine too.
By the way when I want to enable KerberosAuthentication on /etc/ssh/sshd_config , sshd prompts
me : Bad Configuration option.
I don't know what is problem , If any one can help me I really appritiate that.
Best Regards.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []