[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Newbie pam question



Ladies & Gentlemen,

I have a strange thing happening on a Redhat 6.1 box. 

For 3 years now, it has been running almost flawlessly as the Samba Print Server for our educational facility.  However, when I routinely changed the root password(By logging in remotely, as root, through SSH, from another RH6.1 box and using the command "passwd".) I get the following results:

I typed passwd
It asked me to enter the new unix password, and I did. 
It asked me to retype the password, and I did. 
Then I received a message similar to "All authentication token rings updated successfully"

I closed the ssh connection, tried to reconnect as root, and got the message "invalid password"
I then tried to login as root on the actual RH6.1 box and got the message "invalid password".

So, I rebooted into single user mode and typed "passwd".  Entered a different password, verified it, and received the message, "All authentication token rings updated successfully".  Rebooted to X and tried to login as root.  You guessed it ... "Invalid Password".

Has anyone experienced anything like this?  Could my PAM be corrupt?  Could password shadowing cause any complications?

Any help would be greatly appreciated.

==============
Kevin P. Reaver


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []