[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: about crypt_blowfish0.4.5



On Sat, Jul 19, 2003 at 06:02:32PM +0800, =?iso-8859-9?B?c2V5eWlkIGFsaSB5/GtzZWw= ?= wrote:
> I have the crypt_blowfish_0.4.5 from the site Openwall

I've mentioned crypt_blowfish on this list when that was relevant, but
I don't think that discussing it much further is appropriate for this
list.  It's not PAM-related unless/until you talk about integration
with PAM (which has been done in pam_tcb).

But I'll reply to the list this one time.

> Firstly I try to implement it in my RedHat8.0 but the glibc libraries doesnt match because
> the code requires 2.1.X and the RedHat8.0 has already glibc2.2.X

It's only the really tiny patch which is for 2.1.3.  That patch is
trivial to do for another glibc version, and that's been done in the
distributions which have included crypt_blowfish and are currently
with newer glibc's.  So you currently have several options:

1. Add crypt_blowfish into your newer glibc manually.  Easy to do
if you have some basic development experience with Makefiles.  You
don't even need to mess with C.

2. Take the updated patch out of one of those distributions (they're
linked from the crypt_blowfish homepage).

3. Let me do the integration of crypt_blowfish into your systems, at
my regular consulting rate for Openwall software.  This will not be
limited to the glibc.

4. Wait until I put out a newer version, with a patch for trivial
integration into glibc 2.2.x+.

> Therefore I installed Redhat7.0 which has glibc2.1.9,then do the comments in the readme file in Crypt_blowfish Package
> ******************************
> Apply the patch provided in this package.  Enter crypt/sysdeps/unix, and rename
> crypt.h to gnu-crypt.h within that directory.  Copy C sources, header
> and assembly (x86.S) files from this package in there as well (be sure
> you don't overwrite the Makefile).  Configure, build, and install the
> library as usual.
> **********
>  "patch -p1 < glibc.2.13.crypt.diff"
> 
>  "configure --enable-add-ons --prefix=/"
> 
>  "make" 
> 
> then while during "make" there was some problems
> first of all  the message 
> " invalid character 45 in exportstr for full-config-sysdirs"
>  occurs many times in screen and then at last
> 
> 
> .......
> /crypt/sysdeps/unix/x86.s:104: Error: too many memory references for `mov'

I can't be sure from just the information you've provided, but my
guess is that you've copied x86.S under the wrong name: it should be
x86.S, not x86.s (note the capital "S").

> what is the optimum system to implement the CRYPT_BLOWFISH
> the requirements?

Any Linux/glibc system will do.

> Also does code have any new version ?

0.4.5 is the latest and fairly recent.  The reason I don't yet include
a patch for newer glibc is because this code primarily lives in Owl
and there we're still with a glibc 2.1.3 clone.

-- 
Alexander Peslyak <solar openwall com>
GPG key ID: B35D3598  fp: 6429 0D7E F130 C13E C929  6447 73C3 A290 B35D 3598
http://www.openwall.com - bringing security into open computing environments




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]