[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem writing module



It sounds like it might be the app. At any rate, I personally use this test harness to get everything ironed out, _THEN_ I start testing with actual apps. It makes it really easy to see what's going on.

http://www.zip.com.au/~dtucker/patches/#pamtest

This is a very hand gem! (Thanks to Darren Tucker!)

- Max

On Jan 21, 2005, at 6:10 am, Thiago Silva wrote:

Hello all.
I'm currently developing a module for PAM and having some difficulties.
First, the module is linked with the NSS lib (from mozilla). Trying it on
login, wverything runs well, pam_sm_authenticate() returns PAM_SUCCESS, and
there comes the problem. The login locks for some time, and then, prints a
message of time out, showing the login prompt again. I have no idea why is
this happening. I've tried to substitude the module's code for the
pam_permit.c code, wich gave me another error: "Login incorrect" (the
pam_sm_authenticate wasn't called and I assume that was because the little
code was linked to the NSS lib and something went wrong when loading the
module)...Does anyone know this behaviour or can help me debugging?? I have
no idea how to debug the login...


Also, I did a little program that uses this module, and, pam_authenticate()
returns PAM_SUCCESS, and then, the shell is available again. So, nothing
strange here. Only when using it with login.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]