[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

PAM upgrade denies root login via SSH

We have a lab machine that is/was setup to allow someone to ssh to the host as root, assuming the users public key has been added to roots .ssh/authorized_keys.

This all worked fine under FC3. We upgraded the box to FC4, now no one is able to ssh in as root. The following error is generated in the /var/log/secure file:

sshd[6048]: fatal: Access denied for user root by PAM account configuration

I've verified that the sshd_config file has not changed.

The /etc/pam.d/sshd file also has not changed.

I'm guessing this is something to do with authconfig or system-auth?

I've tried a couple of changes there, but no joy.

There are other PAM related problems, but if I can get this part working, I don't have to worry about my connection dropping (since the lab is difficult to access physically).

I would normally handle the need for root via sudo, but this is one of those "special" circumstances. The box is strictly a target for testing, resides by itself on an private, isolated /29 and is physically hard to get to. For this particular setup, I have to be able to come in via ssh as root. It's a long story. ;)

More than anything, I'm mostly interested in what has caused this and how to fix, just as a point of curiosity.

Any help would be appreciated.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]