[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fwd: Failed test: tst-sem5]

   I ran that check again later and it worked.

After 'make subdirs=nptl check':

# ./tst-sem5
sem_timedwait succeeded

I guess I'll try a make install later.


-------- Original Message --------
Subject: Failed test: tst-sem5
From: "Alan Willis" <alan cotse net>
Date: Mon, October 21, 2002 8:37 pm
To: <phil-list redhat com>

   On a fresh redhat 8 install, I did the following:

Installed gcc 3.2-10 and binutils from source rpms.

Built a vanilla 2.5.44 and booted it, the module build dir symlink
properly points /lib/modules/2.5.44/build/ to /usr/src/linux-2.5.44.

Installed autoconf 2.13 from the provided redhat binary and symlinked
/usr/bin/autoconf to that version.

Grabbed nptl 0.4 and glibc 2.3.1, untarred glibc, and nptl as a subdir.

Configure looked like this (from config.status):

 ./configure  --prefix=/usr --enable-add-ons=yes --with-tls
--disable-profile --enable-kernel=current

During the configure I noted that the check for __thread returned with

I ran make ( it seemed to build fine), and ran 'make subdirs=nptl
check', and it failed with the following:

gcc -nostdlib -nostartfiles -o tst-sem5
-Wl,-dynamic-linker=/lib/ld-linux.so.2   -Wl,-z,combreloc ../csu/crt1.o
.../csu/crti.o `gcc --print-file-name=crtbegin.o` tst-sem5.o
libpthread.so libpthread_nonshared.a
.../libc.so.6 ../libc_nonshared.a -lgcc `gcc --print-file-name=crtend.o`
GCONV_PATH=../iconvdata LC_ALL=C   ../elf/ld-linux.so.2 --library-path
../tst-sem5  > tst-sem5.out
Didn't expect signal from child: got `Segmentation fault'
make[1]: *** [tst-sem5.out] Error 1
make[1]: Leaving directory `/home/alan/glibc-2.3.1/nptl'
make: *** [nptl/tests] Error 2

Any ideas?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]