[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PPC64 and nptl/shlib_versions



On Tue, Aug 12, 2003 at 08:50:56AM -0500, Steve Munroe wrote:
> Jakub Jelinek writes:
> 
> > On Mon, Aug 11, 2003 at 02:06:36PM -0500, Steven Munroe wrote:
> > > There is no line in nptl/shlib_versions for powerpc64. I assume it 
> needs 
> > > one? GLIBC_2.3
> 
> > Why? It is not needed:
> > SONAME version gets assigned by nptl/shlib-versions's:
> 
> So when is it appropriate/required to specify a base release in 
> nptl/shlib_versions?

When the SONAME version is different from the default or when
the base symbol version is different from the default (given in DEFAULT
in toplevel shlib-versions resp. GLIBC_2.0 if no DEFAULT applies).

> Or stated another why does x86_64 have a line in nptl/shlib_versions
> specifying GLIBC_2.2.5?

No reason. It can be taken out without problems.

	Jakub




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]