[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Recently introduced incompatibility?



Hi,

I just installed glibc from cvs and noticed an error during make install. Right after make installed libpthread.so all files linked to that library started segfaulting (including make itself). Gdb suggested problems in __pthread_initialize_minimal_internal. I used LD_LIBRARY_PATH to point to another nptl library and this workaround helped me complete the install. Now all programs linked to libpthread work normally again, but segfault when LD_LIBRARY_PATH points to an older version.
I guess the nptl library required another part of glibc (libc.so maybe?) to be installed before it could initialize. Is this incompatibility supposed to exist? (If so, shouldn't the make install order be changed?)
My previous glibc install was from 10-10.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]