[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Recently introduced incompatibility?



Ulrich Drepper wrote:

I'm not sure I understand but I assume you installed only a new libpthread.so, leaving libc.so etc alone?



No, sorry for being unclear. I went through the normal steps: $ cd libc $ cvs -q -z7 update -dP $ mkdir build $ cd build $ ../configure --prefix=/usr --enable-add-ons=nptl \ --enable-kernel=current --disable-profile --with-tls $ make && make check && make install The thing is, 'make install' starts installing, and after a while comes to 'make -C nptl subdir_install'. I assume it installs libpthread.so then. It continues: 'make -C resolv subdir_install', but make (which is linked to libpthread) crashes and the install fails. So the system is stuck with an only partly installed glibc and programs like make, diff, tar and ls don't work anymore.

Here's what I did after that:
I ran /lib/libc.so.6 which showed that it was still the old version.
$ make -C resolv subdir_install
Segmentation fault
$ gdb make
Gdb's backtrace showed __pthread_initialize_minimal_internal was the
last normal instruction before the actual crash. main() wasn't called.
$ ls
Segmentation fault
So I figured every program linked to libpthread was crashing
$ mount -t ext3 /dev/hda2 /mnt/redhat
I mounted my rh9 partition to try the following
$ LD_LIBRARY_PATH=/mnt/redhat/lib/tls ls
Doesn't crash, so
$ LD_LIBRARY_PATH=/mnt/redhat/lib/tls make install
Which goes through the install without problems up to
scripts/test-installation.pl, which gives an error.
$ ls
Doesn't crash, but
$ LD_LIBRARY_PATH=/mnt/redhat/lib/tls ls
Segmentation fault
$ make install
This time it runs all the way and exits without error.

All's well again, but it left me wondering whether there was some sort
of incompatibility, because 'LD_LIBRARY_PATH=/mnt/redhat/lib/tls ls'
apparently worked with the glibc+nptl from 10-10, but not anymore. And I
wondered why 'make install' could fail after installing libpthread.so.

Maybe the install process assumes that 'make' doesn't depend on libpthread?





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]