[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: How to install NPTL?



Thank you for your answers, but my problem is to install not a whatever version of NPTL.
In fact I would like to test both the latest releases of NPTL and NGPT.


I tried to install NPTL 0.46 and when I run the "Make" command I obtain the following error:

******************* cut *************************

version GLIBC_2.3.3 not defined for libpthread
/home/nptl/glibc-2.3.2/build/libBrokenLocale.map is unchanged
/home/nptl/glibc-2.3.2/build/libc.map is unchanged
/home/nptl/glibc-2.3.2/build/libcrypt.map is unchanged
/home/nptl/glibc-2.3.2/build/libm.map is unchanged
/home/nptl/glibc-2.3.2/build/libpthread.map is unchanged
make[1]: *** [/home/nptl/glibc-2.3.2/build/sysd-versions] Error 1
make[1]: Leaving directory `/home/nptl/glibc-2.3.2'
make: *** [all] Error 2

****************** cut *************************

My steps were:

# mkdir /home/nptl
# cp glibc-2.3.2.tar.gz /home/nptl/
# tar xzvf glibc-2.3.2.tar.gz
# cp nptl-0.46.tar.bz2 /home/nptl/glibc/
# tar xjvf nptl-0.46.tar.bz2
# mkdir /home/nptl/glibc/build
# cd home/nptl/glibc/build
# ../configure --prefix=/usr --enable-add-ons=nptl --enable-kernel=current --with-tls
# make


then...I obtain the make error!

I use:  kernel 2.5.70-bk17
          gcc 3.3
          binutils 2.13.90.0.18
          Red Hat 9

and my /lib/modules/$(uname -r)/build links to the /usr/src/linux-2.5.70
Someone can suggest me something about this problem?


Thank you very much,

Riccardo-Maria Bianchi




Christian Leber wrote:


On Mon, Jun 16, 2003 at 05:22:16PM +0200, Riccardo-Maria Bianchi wrote:



maybe this is a silly question but...

...can anyone tell me the steps to do to install NPTL on a i686 machine?



As said, the easiest way is to install Redhat 9.


Another way is a Debian unstable with kernel >=2.5.70 (and >=686 is
needed) and packages from here: http://ijuz.uugrn.org/nptl-0.46-0/
(of course anything could happen, this is only for testboxes)
(The only known problem at the moment I have is that I can't start
"portmap", I allways get:
"/sbin/portmap: relocation error: /sbin/portmap: symbol errno, version
GLIBC_2.0 not defined in file libc.so.6 with link time reference"
but this is not a nptl problem, I think.)

They work for me at least on my UP box, with 0.45 i had some problems
on smp, i'll try again. (I have not allways access)
With this programm:
http://ijuz.uugrn.org/thread_bench/synctest-condmutex.c
But from the 0.46 changelog, I guess it is fixed.


Christian Leber









[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]