[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: nptl 0.49

Rhino wrote:

got this error when compiling :

p/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/shlib.lds /var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/csu/abi-note.o -Wl,--whole-archive /var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/nptl/libpthread_pic.a -Wl,--no-whole-archive /var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/elf/interp.os /var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/libc.so /var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/libc_nonshared.a /var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/elf/ld.so /var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/nptl/libpthread_pic.a(pthread_cond_wait.os)(.gnu.linkonce.d.DW.ref.__gcc_personality_v0+0x0): undefined reference to `__gcc_personality_v0'
collect2: ld returned 1 exit status
make[2]: *** [/var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/buildhere/nptl/libpthread.so] Error 1
make[2]: Leaving directory `/var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2/nptl'
make[1]: *** [nptl/others] Error 2
make[1]: Leaving directory `/var/tmp/portage/glibc-2.3.2_p3/work/glibc-2.3.2'
make: *** [all] Error 2

system: x86 / gcc-3.3

This appears to be a tools problem, likely ld. I initially got the same error using gcc-3.3 and binutils from 030623. I tried to build again using a cvs gcc-3.4 and binutils from early june and it finished compilation successfully. So maybe something that was introduced to the tools in recent weeks is causing grief.

Despite successful compilation, I got a test failure. I can't give you the details now because I'm booten into shwindows. I'll get back to the list with details in a couple of hours.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]