[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: USB Camera - Detected through Kudzu but not configurable throughgtkcam



Jef Spaleta wrote:
On Tue, 2003-02-04 at 19:48, Jim Cornette wrote:


My point was that dumbing down the interface wouldn't attract the
mainstream users for long. If they were to just buy a product off of the
shelf and not check to see if it was supported by Linux.Most people
would blame the computing environment and not the hardware device
distributor.

If people want to be blind to the realities of what it takes to do
hardware support I can't stop them...and I'm pretty sure the developers
at redhat know how important it is to get all the gadgetry working.
Look...a lot of hardware when it comes out gets supported in windows and
mac initially because the hardware manufactures included the necessary
drivers to get the device working. I doubt MS hacks away on device
drivers without a significant effort on the hardware manufacturers part
to work with MS. Chicken and egg problem at this point....if hardware
manufacturers would play ball and just make an effort to publish
reasonable specs(or use standard protocals, and luckily it seems digital
cameras are finally standardizing somewhat from my small amount of
reading on the subject)...things get much easier for everyone. Redhat
does not have the developer man power to reverse-engineer a system for
every addon piece of hardware in existance...throw away peripherals like
digital cameras are rightly pretty low on the developer how to spend
time wishlist...compared to say video cards....

Their work on video cards is a successful and very important project. The desktop computer that I have now, a PowerSpecPC was successfully detected. The card was not detected with the Potato distribution of Debian. Which I tried to have a different distro for Ximian.


The video card detection was more sucessful than Win2k or w98se. Both those versions gave me only 16 colors. GREAT JOB to those that are working on the video cards.

I do have a problem with my 490CDT Toshiba laptop though. For some reason, the X server does not shut down properly. I also will have lockups if I try to CTL-ALT-F(1-5).

I had this problem on distros after version 7.1. Before this version, the display closed down properly and I could open a virtual terminal.

Since I remember ximian adding some kernel-stub package, for those using earlier kernels, that XFRee86 didn't work without. I guess this is related to the newer way that XFree86 deals with the kernel.

I haven't gone back to 7.1 and tried out to see if X exhibited this same problem, if upgraded to the newer X version with the kernel-stub or the most current kernel.

My main point, for asking about this annoyance, is for trying to figure out if the bug should be submitted to version 7.3, 8.0, XFree86 or a kernel related issue.


But you touch on a much harder problem of hardware certification....and its come up on the beta lists in the past...how would anyone actually organize a box branding effort that certified a product as being linux supported. Products can claim windows or mac support becuase MS or apple sells the brand to put on the box, and supposedly have some testing done to actually see if the device works. If Redhat started doing this unilaterally in the linux world..so that addon hardware were branded as "Redhat" compatible...it would spark a heated religious battle and more Redhat=MS-linux flames. But trying to brand any hardware as "linux" compatible would be a major task...

I don't think that most people really pay attention to the logos anyway. It seems to be more of an issue of what is cheapest and has the most features for the money.


Branding Red Hat as M$-Linux seems to be the trend for competing distributions. I'm lucky to get anyone to switch over to Linux. I did sway a few people to try it out or switch from one distro to Red Hat.

If there ever becomes some collaborative effort between distros to pool their resources into some Linux certified program. It would make the task a bit easier. For low cost devices, the results might be worth the collaboration.



It would serve these developers to add a prompt screen for the users to
take the product back. "There is no Linux support from the vendor for
this product." Having a prompt that tells you that your camera is not
detected shades the blame on the lack of the developer's motivation.


Thats a very good idea.....right out in the users face....and again the
idea for this at the Redhat distribution level has been debated on
previous incarnations of the beta list. Not to rehash it...i forget who
I argued about with for like 80 or so messages in one thread, but the
idea that Redhat use its hardware compatibility list on its website in a
more prominent way seems to be popular impossibility  I think it might
be a very clever thing indeed if redhat could tie its hardware
compatibility database on its website into kudzu somehow and be able to
give users an up2date representation of what hardware was
supported...and what wasn't as soon as you plugged it in.



Maybe incorporating the information from the hardware ID and vendor can spawn a browser (full blown or a mini browser) to pinpoint either a locally (updated periodically on-line) or connecting to the supported hardware list on-line.


I will look into the flash readers. Though for the camera presently,
I'll boot into windows and download them. Maybe dropping a line to
gphoto will get some results for more camera support.


Sandisk SDDR-31 USB cf reader works well enough for me.

I'll check my local computer store for this model. Thanks for the suggestion.





Now, about which project the drivers for recognition of hardware. I
would venture that it is best to have the device interact through the
"platform".


It is best for the platform to configure the hardware...ala kudzu...but
if the underlying project Redhat is relying to provide support for a
certain class of devices (gphoto for cameras, sane for scanners) doesn't
support the device, redhat probably can't do much about it except wring
their hands in frustration...there are so many unsupported
peripherals...if it were just a matter of manhours to code it all up,
redhat could prob throw some developer time and money at the problem and
make some progress...but if the underlying problem is some serious
reverse-engineering of oddball devices...well thats prob not a wise use
of distribution level developer time.

I agree! If sane didn't make my scanner useful in Linux. I wouldn't have even ventured into trying out USB interfaced devices. Before the success of the scanner, the USB mouse was all I dared venture to.


I guess that the more that works through Linux. The higher the expectations become.

I still use my 3COM PCI card from earlier days. I have several 3COM ISA cards for older computers also. I hope they don't drop support for these harder to find cards.

Finding a workable ethernet card for my laptop took a few trips back to the store. I had to fanigle with it a lot, to get it to work. But the usefullness far outweighs the usefullness of a camera.

Hopefully, this SMC8041TX will be added to the hardware selection list. This vendor did supply driver information. pcnet_cs

After adding vendor information to the /etc/pcmcia/config file for Phoebe2. The ethernet card was still not recognized. I had to use my config file from the 7.3 installation instead. The file permissions set to 644 for the phoebe version and the file permissions for the 7.3 and 8.0 being 755 confused me a bit.

The strange thing after making the switch in files. Running dhcpcd, hostname and modeprobe myhostname from the /etc/rc.d/rc.local file. I got the following rsults from the below programs.

kudzu - recognized card, but segfaulted. Whole terminal was awash in random patterns, so I couldn't read any information displayed on the terminal.

dhclient - sucessfully polled for a dhcp address from the router. Earlier, with 8.0 it would not sucessfully poll for an address.

neat - before reverting back to the old (7.3 version) /etc/pcmcia/config file. I ran neat and could not get an ethernet card setup through the program. I could not find an option to configure manually or add vendor to the list. --- after reverting the older file, I was getting my card recognized as a "D-Link DE-650 / Lynsys" I did not try to de-activate the interface through neat. I was too afraid to.

Hopefully, there will either be a "cowboy" feature to add new devices or a disregard for the device id halting the interface from being saved.
This feature would have been benificial for the unlisted ethernet card and for the camera. A "warning, this may damage your hardware or crash your computer" might be added. But erroring out, with no options is a bit frustrating.



Jim


Below is vendor supplied information again for my pcmcia card.

                      SMC Networks, Inc.
                       SMC 10/100 PC Card
		    Linux Driver Installation

Most Linux systems support SMC 10/100 PC Card already.

1. Insert the PC Card in the PCMCIA or Cardbus slot in the notebook, and
   reboot the system.  If the file /etc/pcmcia/config exists,add following
   lines in this file:

   For PC Card:
   --------------------

   card "SMC 10/100 PC Card"
   version "SMC", "8041TX-10/100-PC-Card"
   bind "pcnet_cs"

Be noted that you have to add the lines in /etc/pcmcia/config in exactly
the same format as shown above, including matching capital and lower case
letters.


  Reboot or excute "/etc/rc.d/init.d/pcmcia restart". If the adapter
  works properly, you can skip the rest of the document.  Otherwise please
  go to the next step.

-jef


--
The Thought Police are here.  They've come
To put you under cardiac arrest.
And as they drag you through the door
They tell you that you've failed the test.
		-- Buggles, "Living in the Plastic Age"





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]