[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

20 minutes with Phoebe3 were enough to find a number of bugs

Dear Red Hat engineers,
here are a few of the bugs I encountered so far. I would like to see at
least the installation bugs get fixed before the final version, cause if
they'll persist, I will have to mention them on my future review of Red Hat
8.1-Final on OSNews.

1. I load the system and I tell it to install GRUB to the / partition (hda2,
swap is hda1), NOT on the MBR. I want my BeOS boot manager there, but I want
to chainload Grub and load Red Hat. So, everything went fine, I reboot, and
then the system tells me that it can't find a booting image to boot or
something. I change the bootmanager to LILO on my other Linux installation
that I have on the same machine, and also couldn't load GRUB. In other
words, I can't load RH 8.1-b3.
So, I load the Phoebe CD and go to rescue mode and chroot to the system. I
see that there is NO /etc/grub.conf over there or anything like it. Anaconda
hasn't installed Grub *at all*. Neither lilo.
So, I reboot with the CD and try to "fool" the system and chose "upgrade". I
go to the boot loader configuration screen and in fact I rebooted and tried
various things there, 4 times. I tried to install LILO, I even told it to
install on the MBR, I checked everything to be fine, but I always get the
same stupid message later in the upgrade process:
"can't find kernel source, your bootloader changes will not happen" or
something to that effect. In other words, the system just wouldn't
(re)install the bootmanager. This is definately a bug, and if it is not, is
just not the right expected behavior.
All that used to work fine before in previous versions, but Phoebe3 doesn't
do it right.

2. Usability problems: On the bootloader screen, when I add more options for
the boot menu, I get a checkbox for the "Default" column, instead of a radio
button. Come on guys, I know you can do better than that. ;-)
Also, in the partition screen, I get that alert window after the "Edit" of
my / partition because my /swap is 512 MB and my physical RAM is more than
that, and that alert greets me with two buttons "Modify Partition" and
"Continue". In my mind, these buttons are vague. Does the "Modify Partition"
means that it will accept my changes and it will modify the partition as
requested, or does it mean that I will go back to the Edit window to modify
my options? (actually it is the second one!!) And the "Continue" does it
mean to make all the changes I requested, or will it take me to another
screen on the window, as a step-by-step kind of thing? Vague and guessy...
Please fix that up.
Also, it is NOT obvious that you need to 'Edit' the network interface and
add IP and netmask numbers in order to make enabled the "gateway IP numbers"
in the main screen. You see, you have a disabled area in that screen, and in
order to enable it, you have to dig another little screen, fill in numbers,
and then save the result and then that area will get enabled. It is just not
consistent because another window inside the "UI tree" needs to do things in
order to activate something in the previous leaf. You should put the IP and
Netmask to the same area as the gateway and automatically enable the area
after the user presses "manually" to configure his network.

3. Nautilus crashed "just like that" after I clicked on Start Here: from the
desktop and then double clicked on Applications.

4. The rhn-applet crashed the second I changed my theme to "Grand Canyon".
Now, that was a mystery crash. :D

5.You have done something to Mozilla that is _really_ annoying. Everytime I
select a URL from its URL drop down menu, it does not load the page, but I
need to press "enter" or the GO button in order to start loading the
requested page! Additionally, if I middle-click a link to open the link to a
new page, the url is not loaded in there, it is just a blank page.

6. Is there any particular reason why except Kugar, NONE of the KOffice
icons are loading via the Gnome menus neither via the terminal? They just do
nothing, don't even give me an error on the terminal.

Please add a gui configurator for the bootmanager, because now, I have to go
back and re-install the whole thing just because grub just doesn't play
right (yeah, I tried grub-install, it is even worse than using emacs)

Thank you,

Editor-in-Chief at http://www.OSNews.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]