[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Loki update tool on Phoebe3



Viestissä Torstai 20. Helmikuuta 2003 23:42, Paul Jenner kirjoitti:
> Runs fine here.
>
> No LD_ASSUME_KERNEL set, run loki_update, finds games, finds update
> sites and lists updates to install.

Yes, all that works, but the segfault happens while actually applying the 
patch. I traced the problem to the loki_patch program, and manually unpacking 
the update packege, replacing the loki_patch with one compiled on Phoebe3 and 
then running update.sh worked.

However, as loki_patch included in the update packege is a statically linked 
executable that worked on previous RHL versions, this means Phoebe3 somehow 
breaks binary compatibility.

I didn't try LD_ASSUME_KERNEL yet, but it wasn't needed on Phoebe1 and 2.

-- 
	Markku Kolkka
	markku kolkka koti soon fi





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]