[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: smbmount hang



> This works for me without problems mounting win2k share.
> 
> mount -t smbfs -o username=user,password=password  //winbox/c  /test

Thanks muchly for the very quick replies!
Believe me I was no great fan of the backslash syntax.
I am happy to be rid of it - I just thought that was what you had to do.

I have done more testing and found that a simple mount does NOT hang.
No matter if the syntax is ugly (backslashes) or nice.
However, this script constantly hangs for me when it has mounting to do:

   #!/bin/sh

   ismounted()
   {
        DIR=$1
        A=`df $DIR | grep $DIR 2>/dev/null`

        if [ "$A" ]; then
                return 0;
        else
                return 1;
        fi
   }

   if ismounted /mnt/winbox/c; then
        echo "C is mounted"
   else
        echo "mounting C..."
        mount -t smbfs -o username=user,password=password  //winbox/c  /mnt/winbox/c
   fi

   if ismounted /mnt/winbox/d; then
        echo "D is mounted"
   else
        echo "mounting D..."
        mount -t smbfs -o username=user,password=password  //winbox/d  /mnt/winbox/d
   fi

Hopefully its me making a dumb mistake.
-dave

=====
Please ignore the following ad...

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]