[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RPM broke (Was: bitten by rawhide? ...)



Elton Woo wrote:
> As the original poster, it looks like I've really messed up:
> I have *both* glib2-2.1.5-1.i386.rpm  _and_
> glibc-2.3.1-26.i686.rpm installed. OTH, I can't remove either one:

Isn't glib2 something completely different to glibc?

> root]# rpm -e glibc-2.3.1-26.i686.rpm
> rpm: relocation error: rpm: symbol pthread_cond_init, version 
> GLIBC_2.3.2 not defined in file libpthread.so.0 with link time reference

Been there done that! I suspect your version of rpm is too new compared to
your glibc. I fixed a similar problem by manually unpacking the rpm rpm
from the phoebe ISOs - something like
cd /tmp; rpm2cpio <rpm-....i386.rpm | cpio -id
and then using the unpacked bin/rpm to upgrade glibc to -30 and rpm to
-50.

	Michael Young





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]