[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM upgrade problems



Chris Hammond (chammond cox net) said: 
> I downloaded and installed the latest RPM version 4.2-0.51
> from Rawhide and now I am getting the following error whenever
> I try to run rpm.
> 
> [root RedHatWS RPMS]# rpm -q rpm
> /usr/lib/rpm/rpmq: relocation error: /usr/lib/librpmdb-4.2.so: symbol
> pthread_cond_init, version GLIBC_2.3.2 not defined in file libc.so.6
> with link time reference
> 
> I tried to remove and reinstall the original version that came with
> Phoebe but I get the error.  What is the recommended way of going back
> or correcting the error?

Install the rawhide glibc, or use rpm2cpio to get a different version
of rpm installed.

Bill





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]