[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libcrypto.so.4 and libssl.so.4 problem with xchat



On Thu, 9 Jan 2003, Frank Jacobberger wrote:

> So in sheer move of desperation I tried to just install xchat, but:
> 
> error: Failed dependencies:
>         libcrypto.so.4 is needed by xchat-1.8.11-2
>         libssl.so.4 is needed by xchat-1.8.11-2
> 
> No I don't think it's ok to use --nodeps
> 
RedHat update the .so version level for openssl-0.9.7
You can either install it and recompile everything,
or install it and symlink the so.2 -> so.4 for libssl
and libcrypto.  Until you get all your other packages
updated.  I don't believe the external api has been
changed as to break backwards compatibility so this
should be safe.  I believe there is also a new compat
openssl version with the so.2 library as well that you
can install side-by-side.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]