[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kerberos and Nessus problem?

On Wed, Jan 22, 2003 at 09:36:01AM -0000, Martinez, Sylvain wrote:
> I just tried to compile Nessus 1.2.7 and 1.3.1 on a fresh Phoebe2 and
> it generates errors.  There are lot of kerberos header it can't find,
> i.e.: krb5.h and com_err.h if I remember well.  Those headers are in
> /usr/include/kerberos/

OpenSSL 0.9.7 can make use of Kerberos ciphersuites, and when it's built
with that code enabled, some of OpenSSL's headers require Kerberos
headers (accordingly, openssl-devel now requires krb5-devel).  To keep
from getting screwed up by this, 0.9.7 also includes configuration data
for pkgconfig [1].

For developers, pkgconfig provides a decent set of autoconf macros and
for everyone it provides terrific ways to slice and dice information
you'd need for building apps with packages which use it.

You can pull up any CFLAGS you need to pass to nessus's 'configure'
script (or add to its makefile, if it doesn't have a 'configure' script)
  pkg-config --cflags openssl (set CFLAGS to this)
  pkg-config --cflags-only-I openssl (set CPPFLAGS to this)

Doing things this way helps insulate you from similar possible changes
in the future (the --libs output is a lifesaver if you're attempting to
link statically).

> Those headers are called from kssl.c (openssl). I had to copy those
> headers to /usr/include for Nessus 1.2.7 to compile. Nessus 1.3.1
> still doesn't compile though.

What specific error messages are you seeing?


[1] http://www.freedesktop.org/software/pkgconfig/

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]