[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pki-devel] Broken build on F15



On 09/12/2011 10:10 AM, Adam Young wrote:
This might b e old news, I haven't gone back through mail yet, but the recent change for F16 and systemd breaks the build. The RPM spec file has a file ommited that is only used on F16. I got things to build with the following change:

diff --git a/specs/pki-core.spec b/specs/pki-core.spec
index eaf0ee2..262636e 100644
--- a/specs/pki-core.spec
+++ b/specs/pki-core.spec
@@ -508,9 +508,7 @@ fi
 %{_datadir}/pki/scripts/pki_apache_initscript
 %dir %{_localstatedir}/lock/pki
 %dir %{_localstatedir}/run/pki
-%if 0%{?fedora} >= 16
 %{_bindir}/pkicontrol
-%endif


 %files -n pki-symkey


It includes the file in F15, but does not use it. I am about to test if the installed RPMs work on an F15 system.
m/mailman/listinfo/pki-devel
Seems to install and run fine.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]