[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pki-devel] [PATCH] - modify spec file requires for tomcatjss and nuxwdog



Please review.

Ade
>From a9486495778c6d32dd4d321731e7c008c54e64ee Mon Sep 17 00:00:00 2001
From: Ade Lee <alee redhat com>
Date: Tue, 12 May 2015 12:35:42 -0400
Subject: [PATCH] Update nuxwdog and tomcatjss dependencies

---
 specs/pki-core.spec | 33 +++++++++++++++++++++++++++++----
 1 file changed, 29 insertions(+), 4 deletions(-)

diff --git a/specs/pki-core.spec b/specs/pki-core.spec
index c82eee2f452003cab38e11fdf89fc79b5ffbc6f6..045a725c14ea2f6919a99650721400321406b9e1 100644
--- a/specs/pki-core.spec
+++ b/specs/pki-core.spec
@@ -33,7 +33,7 @@ distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
 
 Name:             pki-core
 Version:          10.2.4
-Release:          0.1%{?dist}
+Release:          0.2%{?dist}
 Summary:          Certificate System - PKI Core Components
 URL:              http://pki.fedoraproject.org/
 License:          GPLv2
@@ -53,7 +53,13 @@ BuildRequires:    apache-commons-lang
 BuildRequires:    jakarta-commons-httpclient
 BuildRequires:    nspr-devel
 BuildRequires:    nss-devel >= 3.14.3
-BuildRequires:    nuxwdog-client-java >= 1.0.2
+
+%if 0%{?rhel}
+BuildRequires:    nuxwdog-client-java >= 1.0.1-11
+%else
+BuildRequires:    nuxwdog-client-java >= 1.0.3
+%endif
+
 BuildRequires:    openldap-devel
 BuildRequires:    pkgconfig
 BuildRequires:    policycoreutils
@@ -101,7 +107,13 @@ BuildRequires:    junit
 BuildRequires:    jpackage-utils >= 0:1.7.5-10
 BuildRequires:    jss >= 4.2.6-35
 BuildRequires:    systemd-units
+
+%if 0%{?rhel}
+BuildRequires:    tomcatjss >= 7.1.0-6
+%else
 BuildRequires:    tomcatjss >= 7.1.2
+%endif
+
 
 # additional build requirements needed to build native 'tpsclient'
 # REMINDER:  Revisit these once 'tpsclient' is rewritten as a Java app
@@ -346,7 +358,13 @@ Obsoletes:        pki-silent < %{version}-%{release}
 
 Requires:         java-headless >= 1:1.7.0
 Requires:         net-tools
-Requires:         nuxwdog-client-java >= 1.0.2
+
+%if 0%{?rhel}
+Requires:    nuxwdog-client-java >= 1.0.1-11
+%else
+Requires:    nuxwdog-client-java >= 1.0.3
+%endif
+
 Requires:         perl(File::Slurp)
 Requires:         policycoreutils
 Requires:         openldap-clients
@@ -382,7 +400,11 @@ Requires(post):   systemd-units
 Requires(preun):  systemd-units
 Requires(postun): systemd-units
 
-Requires:         tomcatjss >= 7.1.2
+%if 0%{?rhel}
+Requires:    tomcatjss >= 7.1.0-6
+%else
+Requires:    tomcatjss >= 7.1.2
+%endif
 
 %description -n   pki-server
 The PKI Server Framework is required by the following four PKI subsystems:
@@ -940,6 +962,9 @@ systemctl daemon-reload
 %endif # %{with server}
 
 %changelog
+* Tue May 12 2015 Dogtag Team <pki-devel redhat com> 10.2.4-0.2
+- Updated nuxwdog and tomcatjss requirements (alee)
+
 * Thu Apr 23 2015 Dogtag Team <pki-devel redhat com> 10.2.4-0.1
 - Updated version number to 10.2.4-0.1
 - Added nuxwdog systemd files
-- 
1.9.3


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]