[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pki-devel] port to tomcat 8.5?



On 12/03/2016 04:00 AM, Timo Aaltonen wrote:
On 02.12.2016 12:01, Timo Aaltonen wrote:
	Hi

   Debian recently switched to tomcat 8.5 which broke Dogtag. First issue that I found was that Http11Protocol is no more, need to use Http11NioProtocol. Fixing that it then fails with:

02-Dec-2016 11:26:05.270 SEVERE [main] org.apache.catalina.core.StandardService.initInternal Failed to initialize connector [Connector[HTTP/1.1-8443]]
  org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8443]]
         at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:113)
         at org.apache.catalina.core.StandardService.initInternal(StandardService.java:549)
         at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:107)
         at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:875)
         at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:107)
         at org.apache.catalina.startup.Catalina.load(Catalina.java:606)
         at org.apache.catalina.startup.Catalina.load(Catalina.java:629)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
         at java.lang.reflect.Method.invoke(Method.java:498)
         at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:311)
         at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:494)
Caused by: java.lang.NoClassDefFoundError: org/apache/tomcat/util/net/ServerSocketFactory
...

I see Fedora is still at 8.0, so no-one has tried 8.5 yet?
Looks like tomcat 8.5 breaks the build as well for both dogtag
and tomcatjss. Debian freeze is in Jan 5th, this needs to be fixed well
before x-mas just to be on the safe side :/

dogtag build log: http://pastebin.com/gabUtiTy
tomcatjss build log: http://pastebin.com/3qrh5Eqp



Timo,

I just looked in Bodhi, and the latest version of Tomcat in Fedora is 8.0.39 (currently in testing).

What version of Tomcat were you using previously from which you upgraded?

Also, does Debian use JBoss?  If so, does Tomcat 8.5 work with that?

-- Matt


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]