[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

valgrind, rpm & libc.

Hello everybody.

I need a little piece of advice about a program called valgrind.
I grabbed the tar.bz file from its website (look for it on
freshmeat.net) and as good redhat user i saw the spec file inside the
tarball and tried to repackaged it. The build did complete without any
problem and then i tried to install it.

During the rpmbuild process there was this : 
Requires: /bin/sh /usr/bin/perl libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.2) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.3) libc.so.6(GLIBC_PRIVATE) perl(strict)

Note the GLIBC_PRIVATE symbol. When i tried to install the i386.rpm i got :
[root enclume ~dnade]# rpm -Uvh /usr/src/redhat/RPMS/i386/valgrind-1.0.4-1.i386.rpm
error: Failed dependencies:
        libc.so.6(GLIBC_PRIVATE) is needed by valgrind-1.0.4-1
[root enclume ~]# rpm --redhatprovides 'libc.so.6(GLIBC_PRIVATE)'
no package provides libc.so.6(GLIBC_PRIVATE)

Does any rpm/glibc/valgrind guru could told were is the "bug" ? The
valgrind spec file do not contain any "Requires" line. Is the glibc
package incomplete ? Is --nodeps a solution ? Does valgrind provide this
symbol but do not provide the RPM dependancy ? Please ? someone ?


	 Dams Nadé
ActiVia Networks : http://www.activia.net/
Association AMIN : http://amin.unice.fr/

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]