[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kernel panic with ext3 root set to writeback



On Thu, 2002-12-19 at 23:26, Kevin McConnell wrote:
> --- Tom Ball <Tom Ball Sun COM> wrote:
> > Has anyone been able to boot Red Hat 8.0 with an
> > ext3 root device with
> > it set to writeback mode?  When I add
> > bootflags=mode=writeback to my
> > kernel line in Grub, the kernel panics because it
> > doesn't recognize the
> > option.  
> 
> Where did you read about the writeback feature? Can we
> look at your grub.conf file? Have you tried putting
> this in your grub.conf file?

Here's the link:

http://www-106.ibm.com/developerworks/linux/library/l-fs8.html?dwzone=linux

Here's my grub entry:

title Red Hat Linux (2.4.18-18.8.0) - Home
	root (hd0,5)
	kernel /boot/vmlinuz-2.4.18-18.8.0 ro root=LABEL=/ rootflags=mode=writeback
	initrd /boot/initrd-2.4.18-18.8.0.img

As someone previously suggested, I also tried adding this information to
/etc/fstab, with the same panic.

BTW, the writeback option support is in (search for "writeback"):

  file:///usr/src/linux-2.4/fs/ext3/super.c

and its use is in:

  file:///usr/src/linux-2.4/fs/ext3/fsync.c

Thanks in advance for any pointers.  Builds sure slowed down when I
upgraded to 8.0, and I'm hoping this will improve things a bit.

Tom





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]