[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: /var/lib/rpm/



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Saturday 21 December 2002 03:59 pm, Craig Toenes wrote:
> A gentleman had suggested that I could fix my GUI
> install problem with:
>               rm -f /var/lib/rpm/_db*
> I did that and got a root prompt.

That should be (2 underscores) __db*

>       The next thing he said to do was:
>               rpm --rebuilddb
> I did that and got a blinking prompt with nothing else
> and nothing happened. I suspect that /var/lib/rpm/
> might be at the root of my problem but I'm not sure.

It will take a few minutes or more depending on the system.

In your case, it looks like you didn't actually remove the lock files, 
causing another hung process.

>                  Any input would be appreciated.
>                  This is my only option because there
> is no other support.  PS.Bugzilla has nothing listed

Hrmm? This has been bugzilla'd many times. For starters:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=73097
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75826
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=77988

Additionally, have a look at:
http://www.rpm.org/hintskinks/repairdb/

- -- 
- -Michael

pgp key:  http://www.tuxfan.homeip.net:8080/gpgkey.txt
Red Hat Linux 7.{2,3}|8.0 in 8M of RAM: http://www.rule-project.org/
- --
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE+BOB2n/07WoAb/SsRAvpaAJ0cVdp/+WCmMqUYo7NOtWFP68a72gCghqAu
JZ3BlX9gk0/OPFlvzAphj5o=
=9kgV
-----END PGP SIGNATURE-----





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]