[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RPM rebuild of Apache - Access Problems



Just wondering if anyone has any suggestions about this.

I rebuilt httpd-2.0.40-11.5 from the RPM source to change the content directory to /home/htdocs, so SUEXEC will work from there. Anyways, had no problem rebuilding RPM, installing it and getting SUEXEC to work like I wanted.

The problem is that with the rebuilt Apache does not seem to be reading .htaccess and .htpasswd files correctly. The LoadModule directive for both mod_auth and mod_access are uncommented. And Apache is not displaying the .ht files through the browser, so it seems like mod_access is partially working.

I tried serveral tests.

.htaccess
    Order Deny,Allow
    Deny from all

The above .htaccess file after restarting Apache did not block access to the directory.

.htaccess
    Order Deny,Allow
    Deny from all
    Allow from xxx.xxx.xxx.xxx

The above .htaccess file after restarting Apache did not block access to the directory.

.htaccess
    AuthType Basic
    AuthName "By Invitation Only"
    AuthUserFile /home/htdocs/samplesite.com/.htpasswd
    Require valid-user

The above .htaccess file after restarting Apache did not make Apache ask for a userid and password before serving the page.

Did I miss something in the spec file when rebuilding Apache?

Any help would be appreciated.


On the desktop - MacOS X In the server room - Linux Windows? In the trash?

_________________________________________________________________
Help STOP SPAM with the new MSN 8 and get 2 months FREE* http://join.msn.com/?page=features/junkmail





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]