[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Building Own Kernel - PCMCIA Woes

Hash: SHA1

Hello psyche-list,

Because of the problems I have been having with the 2.4.20 kernel
updates for RH 8.0, to which no one seems to even be able to provide a
hint on tracking down, I decided to have a go at grabbing the latest
stable kernel from www.kernel.org. I downloaded 2.4.21 dated
2003-06-13, in hopes that whatever broke between .18 and .20 got fixed
in .21.

So, I extracted the kernel source onto a filesystem with a bunch of
free space, as /data/kernel/linux-2.4.21, and followed the kernel
build instructions. Since this is a notebook computer that is not
likely to have any changes in sound card, processor, etc., I tried to
set everything up that it had (that I use all the time) as "y" to
include. Anything that I use only occasionally, I set up as "m", and
anything that doesn't exist or never is used, I set up as "n".

I've got six saved .config files at this point, but the first couple
don't really count, since I didn't even *try* to boot them. I have
attached rh5.config (rh for Ron Heiby, not Red Hat) to this message,
as it seems to be the closest to working. The change going from this
to rh6.config was to make CONFIG_PCMCIA and CONFIG_PCMCIA_3C574 "m",
rather than "y". With those changes, the kernel would not build, with
the final "ld" complaining about not being able to find
drivers/char/pcmcia/pcmcia_char.o, and with me wondering why it would
want to look for such a file.

Anyway, back to the attached config. The system boots just fine, but
no Ethernet. My Ethernet is a Megahertz PCMCIA combo card that runs
with no problem on the 2.4.18-27.8.0 stock build, while causing all of
the 2.4.20 builds to die horribly.

Looking at /var/log/messages, the best clue seems to be that it is
trying to "modprobe memory_cs", a module that does not exist. But, it
does not exist in any of the kernels I installed from .rpm files,
either. So, I'm obviously confused.

I ran across <http://www.oreillynet.com/pub/faqs/linux_faq_AEN2325>,
which seems to be telling me to turn off all the PCMCIA stuff in the
kernel build, and to re-compile the "kernel-pcmcia-cs-"
package, pointing it at my new kernel source tree. While that seems to
make some sense, I have to wonder why the kernel-pcmcia-cs package
didn't have to be re-done for the 2.4.18 -> 2.4.20 transition. If I
don't hear/find something that seems to make more sense by the time I
get home from work, that's what I'll be trying next.



Version: PGP Personal Privacy 6.5.8
Comment: Until recently, the last PGP with full source disclosure.


Attachment: rh5.config
Description: Binary data

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]