[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Partial Resolution - PCMCIA v Recent Kernels + CD-R DMA v Hang v Losing TIme, now Too much work at interrupt



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello psyche-list,

I've had a few problems with my ThinkPad 770ED in the Dock on my desk
for a while. Recapping:

I was stuck at the 2.4.18 kernel because everything newer that I tried
hung when trying to initialize the Ethernet PCMCIA card. Further, I
was unsuccessful in downloading and building a kernel that would
initialize and use the Ethernet PCMCIA. No one was able to provide any
pointers on what else I might try to correct or track down the
problem.

Using DMA access with the CD-R/RW drive in the dock worked
beautifully -- most of the time. Unfortunately, every now and then, it
caused a full system freeze. Disabling DMA to the drive seems to have
eliminated the lockups, at the cost of the system clock losing 4-5
minutes when burning a CD-R or when verifying that a CD-R was
correctly written. No one was able to provide any suggestions.

The lightning bolt hit me the other day. This system is semi-retired.
It sits on the dock all day every day. I do not actually *need* to
have PCMCIA Ethernet. There are ISA and PCI slots in the dock!

So, I went to CDW and plunked down $10 for a USR PCI Ethernet card
that claimed Linux as a supported OS. I installed it in the third slot
in the dock, removed the PCMCIA card, and re-booted (still 2.4.18).
Things looked pretty good, except that any significant amount of
Ethernet activity (like refreshing my VNC session) would hang the
system. After much searching through logs, Google, and old neural
pathways, I thought maybe to try a different PCI slot. I moved the
card to slot 2, and the system no longer hangs! Further, I updated to
and booted from the latest RH 8 kernel (2.4.20-27.8), which also
worked just fine.

One of the unexpected benefits of the new kernel is that the clock no
longer loses time when I use the CD-R/RW drive. I have not yet tried
re-enabling DMA to the drive.

The only other remaining issue is new with the current setup. Although
the system does not hang with Ethernet activity, /var/log/messages
gets a *lot* of messages like:

[datestamp] rwh kernel: eth0: Too much work at interrupt,
IntrStatus=0x0001.
[datestamp] rwh kernel: eth0: Too much work at interrupt,
IntrStatus=0x0040.

The second message seems to be the more "popular". Doing some Google
searching, I was able to find several references to people seeing such
messages, but no solutions. I was also able to find some discussion
related to 2.5.N kernels.

The problem appears to be related to the fact that Linux has decided
to lump a whole bunch of things together on the same, single, IRQ.
Looking at /proc/interrupts, I find that IRQ-11 is associated with
aic7xxx, usb-uhci, usb-uhci, eth0, Texas Instruments PCI1250, Texas
Instruments PCI1250 (#2). From the looks of this list, I'd say that it
covered pretty much all of the devices in the Dock. Booting back into
Windows (which I hadn't got 'round to blowing away), I ran the
ThinkPad setup utility and tried to allocate additional interrupts to
the Dock, but the option was disabled, even after I disabled a couple
of things like the Infrared port and should have had at least 2 free
IRQs.

So, I'm at a loss as to how to clear this up. If it were just the
messages, I'd ignore it. However, the only two bad CD-R burns I've had
in many months appeared this week, being burned while there was
significant Ethernet activity and lots of the "Too much work"
messages. Also, large file copies via Samba/Ethernet seem to be quite
slow (even though VNC session responsiveness appears to have become
much improved). I have not dared try accessing the removable HD on the
SCSI bus that shares the same interrupt. (Fortunately, I have a
similar drive on another system, although it's running Windows.)

Any ideas on the interrupt issue would be appreciated. I suppose now
that I've dumped the PCMCIA, I could try the 2.6 kernel. Anyone know
whether it might fix this problem? I also have downloaded Fedore Core
1 and burned CDs. I also have the Mandrake 9.2 on DVD glued to the
cover of a pretty decent UK Linux mag. Anyone have an opinion on
whether upgrading to one of these (or another distro) might help?

Thanks!

Ron.

-----BEGIN PGP SIGNATURE-----
Version: PGP Personal Privacy 6.5.8
Comment: Until recently, the last PGP with full source disclosure.

iQA/AwUBP/L1828pw+2/9pUJEQK4dACeLSGT/UMyUVlAMy7Oz9/kBStW1YoAoIXr
QJAZgM5Hkjjq0OykCPE6lLsO
=G98z
-----END PGP SIGNATURE-----




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]