[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

locale problem



Hello and thanks in advance for all help!

I am migrating a about 50 desktops from Redhat 7.3 to 7.3, and run into
problems with the locale settings, due to wanting the the menus and info
in English but with Swedish support.

Our systems all have Swedish keyboards, however we prefer to have the
system in English.

In my Kickstart I have set:
lang en_US
langsupport --default en_US sv_SE

which in 7.2 was fine, however in 7.3 gnome-terminal no longer
recognizes the last three letters of our alphabet, the non english äåö. 
xterm works fine.

I tried to modify /etc/sysconfig/i18n but have been unable to come up
with the proper configuration.

The default is:
LANG="en_US.iso885915"
SUPPORTED="sv_SE.iso885915:sv_SE:sv"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"


When I set it to (hoping C should encompass everything):
LC_ALL="C"
LANG="C"
SUPPORTED="en_US:sv_SE.iso885915:sv_SE:sv"
SYSFONT="lat0-sun16"
SYSFONTACM="iso15"

I still get:

[xxx xxxx user]# gnome-terminal 

Gdk-WARNING **: locale not supported by C library

and the characters not supported. Changing LANG= to sv_SE gives the
characters but all menus and such become Swedish, and since we have an
international group which consists of many non Swedes that does not work
for us.

Thanks again for all suggestions.

Sincerely,

Scott Melnyk

Stockholm Bioinformatics Center





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]