[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Minor bug (majorly annoying) in X11 and mouse

With a fresh install of RH8.0 set to graphical login (using PS/2 mouse)
if you pull out the mouse and reboot what do you get? What would you
expect to get?

It can be really hard talking someone through a support call when their
only report is "I'm looking at a black screen" and they try ALT-F1 from
the console to still get a black screen, and they try CTRL-ALT-F1 from
the console and STILL get a black screen. Even after several minutes the
X11 keeps respawning and doesn't get disabled so you basically have
absolutely no console access at this point. I would expect that it would

 [1] Start X11 anyhow and just not give you a mouse (so the user
  gets the idea, "hey my mouse is gone, maybe it isn't plugged it")

 [2] Disable X11 completely because it keeps crashing (the slowness of
  the X11 startup seems to protect it from init disable, maybe this
  depends on hardware).
 [3] Bring up X11, pop an error that gives the user something readable
  and hang there in space (at least allowing CTRL-ALT-F1 to get a text
  console plus the user knows what is wrong).

	- Tel

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]